Uncover it - Link Uploads don't work. – Incident details
Report an issue
Get updates
Email
Slack
Microsoft Teams
Discord
Google Chat
Webhook
RSS
Atom
API
Report an issue
Get updates
Dark mode
Language
All systems operational
Link Uploads don't work.
Resolved
Partial outage
30 %
Started 29 days ago
Lasted 1 day
Affected
Main
Partial outage from 8:20 PM to 8:52 AM
Website
Partial outage from 8:20 PM to 8:52 AM
Updates
Resolved
6th Jun, 2025 at 8:52 AM
Resolved
6th Jun, 2025 at 8:52 AM
This incident has been resolved.
Investigating
5th May, 2025 at 8:20 PM
Investigating
5th May, 2025 at 8:20 PM
We are currently investigating this incident.