Uncover it - File details sometimes shows up as 'Unknown File' and 'NaN MB' – Incident details
Report an issue
Get updates
Email
Slack
Microsoft Teams
Discord
Google Chat
Webhook
RSS
Atom
API
Report an issue
Get updates
Dark mode
Language
All systems operational
File details sometimes shows up as 'Unknown File' and 'NaN MB'
Resolved
Partial outage
Started about 1 month ago
Lasted 17 days
Affected
Main
Partial outage from 6:30 PM to 10:20 AM
Website
Partial outage from 6:30 PM to 10:20 AM
Updates
Resolved
4th Apr, 2025 at 10:20 AM
Resolved
4th Apr, 2025 at 10:20 AM
This incident has been resolved.
Investigating
4th Apr, 2025 at 6:30 PM
Investigating
4th Apr, 2025 at 6:30 PM
We are currently investigating this incident.