Uncover it - Link uploads don't work – Incident details

All systems operational

Link uploads don't work

Resolved
Operational
Started 4 months agoLasted about 1 hour

Affected

Main

Degraded performance from 7:19 PM to 8:38 PM

Website

Degraded performance from 7:19 PM to 8:38 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified
    We are continuing to work on a fix for this incident.